Arcam software setup page

Pre-requisites

  • Be sure your Windows version is up to date by running Windows update.
        Run Windows Update
  • That .Net Framework 3.5 SP1 and .Net Framework 4 (or later) are installed.
        Install .Net Framework 3.5 SP1
        Install .Net Framework 4.0
  • Arcam software can only run with administrator privileges - make sure you are logged in as an administrator.

    Downloads

    Use Internet Explorer. Firefox and other browsers may have problems installing the software.
    Please install the applications in the following order:
    1. HASP Driver setup
    2. EBM Control SP2
    
    3. Log Studio 3.2
    
    4. VC++ Runtimes for x86 systems<- Always install!
    5. VC++ Runtimes for x64 systems<- Install only for x64 systems!
    6. Build Assembler
    

    License file

    To run Build Assembler and EBM Control you will need a license-key to a third party component. Arcam support will help you to obtain a personal license.

    Troubleshooting